Вверх ↑
Этот топик читают: Гость
Ответов: 8338
Рейтинг: 775
#346: 2012-12-21 11:02:11 ЛС | профиль | цитата
CriDos, [flood]Ну вот, а то всё "Конец света, конец света...", а у нас даже на Windows 8 x64 полёт прекрасный [/flood]
карма: 14

0
Ответов: 1841
Рейтинг: 362
#347: 2012-12-21 14:22:04 ЛС | профиль | цитата
Леонид, [flood]У меня конец света происходит каждые сутки, с 00:00 по 07:15 по МСК...[/flood]
карма: 1
0
Ответов: 379
Рейтинг: 57
#348: 2013-01-31 16:52:13 ЛС | профиль | цитата
Не работает "Профиль элемента". В официальной сборке работало. Если не трудно, пользователи этой сборки посмотрите работает у Вас или нет?
За ранее спасибо!
карма: 0

1
Голосовали:CriDos
Ответов: 1519
Рейтинг: 174
#349: 2013-01-31 18:22:24 ЛС | профиль | цитата
Poputchik писал(а):
"Профиль элемента"
Не понял, а, где его посмотреть?
карма: 1
Не так страшна ошибка, как опасность её не заметить.

0
Ответов: 1376
Рейтинг: 197
#350: 2013-01-31 19:20:38 ЛС | профиль | цитата
Poputchik писал(а):
За ранее спасибо!
заранее спасибо
карма: 1

0
Ответов: 379
Рейтинг: 57
#351: 2013-01-31 20:07:49 ЛС | профиль | цитата
foksov,
[flood]Тактичный человек не сделает замечания кому либо в присутствии других людей...http://window.edu.ru/library/pdf2txt/023/41023/18328/page3[/flood]

ser_davkin писал(а):
Не понял, а, где его посмотреть?

Профиль элемента
Находится на панели "Свойства" элемента внизу
карма: 0

0
Ответов: 25
Рейтинг: 0
#352: 2013-02-03 00:29:08 ЛС | профиль | цитата
скачал сборку посмотрел возникло несколько вопросов...
1. проект python exe- не создается ? только типо project1.py ?
2. возможности создать не под win не существует .. например скрипт.ру чтобы запустить на роутере под openwrt с поставленым пакетом python ?
3.как добавить в пакет win возможность вставки скрипта на python , компонент - вставка скрипта php ведь есть ?
карма: 0

0
Ответов: 5446
Рейтинг: 323
#353: 2013-02-03 03:03:34 ЛС | профиль | цитата
seagai,
1. Надо поставить py2exe, но он есть только для Python 2.x. Впрочем, весь пакет Python сделан под ветку 2.x.
2. Можно. Для этого архив из аттача распаковываешь в Hiasmcompiler и выполняешь файл pycode.his
3. В пакете Win компонента "вставка скрипта php" нет.
------------ Дoбавленo в 03.03:
CriDos, обновишь пакет Python в сборке?
карма: 1

0
Ответов: 25
Рейтинг: 0
#354: 2013-02-03 03:12:58 ЛС | профиль | цитата
iarspider писал(а):
Надо поставить py2exe

посмотрел вроде в компиляторах при инсталяции сборки есть файлы..
py2exe.exe и есть pycode.exe
только при нажатии компилировать появляется project1.py и setup.py
что не так делаю ?
что делает pycode.his ?

если нет компонента под win для вставки кода python было бы неплохо наоборот - в проекте python компонент (использования/вызова) внешней dll как в win проекте.. + компонент вставка кода python
карма: 0

0
Ответов: 5446
Рейтинг: 323
#355: 2013-02-03 12:22:55 ЛС | профиль | цитата
seagai, а у Вас сам python-то установлен? Он в состав сборки не входит. pycode.his прописывает в среде дополнительный "компилятор" (по сути - утилиту для конвертации из CP1251 в UTF-8), позволяющий на выходе получить py, а не exe.

По поводу DLL: создать универсальный компонент не получится. Для каждой конкретной библиотеки можно ручками писать модуль, заворачивающий с помощью ctypes вызовы функций в методы класса, и подключать по событию onImport. Подробности выпытывайте у гугля, я этим не занимался никогда. Кстати, если библиотека не сильно экзотическая, то скорее всего тот же google подскажет, где взять готовую обёртку.
карма: 1

0
Ответов: 25
Рейтинг: 0
#356: 2013-02-03 17:11:41 ЛС | профиль | цитата
iarspider писал(а):
По поводу DLL: создать универсальный компонент не получится

так компонент то нужен для подключения библиотеки сделанной через компонент в проекте win hiasm
python поставил http://www.python.org/ftp/python/2.7.3/python-2.7.3.amd64.msi, а дальше все равно не понятно как exe делать как с ним увязывать ..

карма: 0

0
Ответов: 1841
Рейтинг: 362
#357: 2013-02-03 19:41:56 ЛС | профиль | цитата
Топик удалён по ошибке
карма: 1
0
Ответов: 25
Рейтинг: 0
#358: 2013-02-04 04:10:57 ЛС | профиль | цитата
Мучился мучился и python инсталировал и патч в системных переменных прописывал все не делает exe и все тут..
Попробовал пакет Android - тоже apk не делает .. ( я ставил java 64 bit так как win7-64bit у меня) поставил обычную java стал apk делать , но там тоже с ошибками
code_30251.txt

вот что в отладке
...
-compile:
[javac] Compiling 3 source files to Crogram Files (x86)HiAsm_AltBuildElementsandroidcode esultinclasses
[javac] Crogram Files (x86)HiAsm_AltBuildElementsandroidcode esultsrchiasmhiasmprojectHiasmMain.java:15: error: cannot find symbol
[javac] sbar1 = (SeekBar) findViewById(R.id.sbar1);
[javac] ^
[javac] symbol: variable sbar1
[javac] location: class id
[javac] 1 error

BUILD FAILED
Crogram Files (x86)HiAsm_AltBuildcompilerandroid oolsantuild.xml:651: The following error occurred while executing this line:
Crogram Files (x86)HiAsm_AltBuildcompilerandroid oolsantuild.xml:672: Compile failed; see the compiler error output for details.




карма: 0

0
файлы: 1code_30251.txt [223B] [101]
Ответов: 3930
Рейтинг: 620
#359: 2013-02-04 14:17:12 ЛС | профиль | цитата
seagai, с вопросами по Android - в соответствующую тему. После установки пакета с инсталлятора, его нужно обновить по инструкции в той же теме.
карма: 19

0
Ответов: 35
Рейтинг: -2
#360: 2013-05-06 10:57:20 ЛС | профиль | цитата
Fasm можно и 1.7 спокойно поставить.
карма: 0
Лень двигатель прогресса.
0
Сообщение
...
Прикрепленные файлы
(файлы не залиты)